Blog > Komentarze do wpisu
Wyszukaj.pionowo

Jedna z bardziej pożytecznych funkcji jest =WYSZUKAJ.PIONOWO().

Wyobraźmy sobie takie zadanie: mamy listź artykułów z danymi w kolejnych kolumnach: symbol artykułu, nazwa artykułu, cena artykułu. Drugie zestawienie to rejestr sprzedaży, w którym mamy zawarty symbol artykułu i ilość sprzedanych sztuk. Jak każdemu artykułowi z rejestru sprzedaży przypisać cenę z listy artykułów? Całą pracę wykona za nas właśnie funkcja =WYSZUKAJ.PIONOWO().

Składnia tej funkcji:

=WYSZUKAJ.PIONOWO(co;gdzie;w_której_kolumnie;prawda/fałsz),

ostatni argument:

fałsz - zostanie wyszukany w tabeli 'gdzie' dokładnie element 'co',

prawda lub pominięty argument - zostanie wyszukany, w przypadku braku dokładnie takiego samego elementu, największy element mniejszy od 'co' (wykorzystać to można do przypisania np. ocen: dla p-któw z przedziału x-y ocena z), tabela 'gdzie' musi być posortowana rosnąco według pierwszej jej kolumny.

Formuła w G2 to:

=WYSZUKAJ.PIONOWO(F2,$A$2:$C$5,3,FALSZ)

piątek, 05 maja 2006, skalnyy
Tagi: wyszukiwanie

Polecane wpisy